Вопрос задан 29.06.2023 в 16:18. Предмет Информатика. Спрашивает Шатохина Арина.

Составьте программу, которая заменяет все положительные числа на -2​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Вавилов Захар.

a = []

N = int(input("Сколько чисел в списке? "))

for i in range(N):

   a.append(int(input()))

for i in range(len(a)):

   if a[i] > 0:

       a[i] = -2

print(a)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая заменяет все положительные числа на -2:

python
def replace_positive_with_minus_two(lst): for i in range(len(lst)): if lst[i] > 0: lst[i] = -2 # Пример использования input_list = [1, -3, 5, 0, 2, -1, 4] replace_positive_with_minus_two(input_list) print(input_list)

Этот код определяет функцию replace_positive_with_minus_two, которая принимает список чисел lst и заменяет все положительные числа в этом списке на -2. После вызова функции с примером списка input_list, результат будет выводиться на экран, и вы увидите, что все положительные числа были заменены на -2.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос