Вопрос задан 29.06.2023 в 03:42.
Предмет Информатика.
Спрашивает Громова Надя.
Помогите, либо блок-схему, либо на Паскаль написать. Дана сумма начисленной заработной платы. Из
этой суммы необходимо удержать 12% на подоходный налог, 1% на профсоюзный налог, 1% на пенсионный налог и добавить 45 %. Полученную сумму к выдаче вывести на экран.Ответы на вопрос
Отвечает Попков Макс.
##
var Начислено := ReadReal('Введите сумму:');
var ПроцентУдержаний := 12 + 1 + 1;
var Удержано := Начислено * ПроцентУдержаний/100;
var Надбавка := (Начислено - Удержано) * 45/100;
var КВыдаче := Начислено - Удержано + Надбавка;
Print('Сумма к выдаче:', КВыдаче)

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вы можете написать программу на языке Pascal для решения этой задачи. Вот код на Pascal:
pascalprogram CalculateSalary; var salary, netSalary: real; begin writeln('Введите сумму начисленной заработной платы: '); readln(salary); // Рассчитываем удержания и добавляем 45% netSalary := salary - (0.12 * salary) - (0.01 * salary) - (0.01 * salary) + (0.45 * salary); writeln('Сумма к выдаче: ', netSalary:0:2); end.
Этот код сначала запрашивает сумму начисленной заработной платы, затем вычисляет удержания и добавляет 45% к оставшейся сумме. Наконец, программа выводит результат на экран.
Похожие вопросы
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
