
Паскаль Написать программу, которая вычисляет Стоимость оплаты за электроэнергию за текущий
месяц. Известно, что СТОИМОСТЬ начисляется по схеме: До 100 кВт - 90 коп. за кВт; От 100 кВт до 500 кВт - 168 коп. за кВт; Более 500 кВт - 224 коп. за кВт; Количество кВт использованной ЭНЕРГИИ вводиться с клавиатуры. Выполнить защиту от неправильного ввода данных Записать конечной результат в файл

Ответы на вопрос

Ответ:
begin
var N,B:real;
write('Введите количество кВт: '); readln(N);
if N<0 then write('Некорректный ввод: значение должно быть положительным') else
begin
case N.Round of
0..99:B:=N*0.96;
100..500:B:=N*1.68;
else B:=N*2.24;
end;
append(output,'output.txt');
write(output,'Использовано энергии '+N+' кВт на сумму '+B+' рублей');
end;
end.
Примечание:
Программа может выдать ошибку при попытке подключения к файлу output.txt в коренной папке Паскаля. В таком случае нужно создать другой файл, и поместить его в ту же папку, после чего заменить имя 'output.txt' на имя нового файла в процедурах append и write.



Вот программа на языке Pascal, которая вычисляет стоимость оплаты за электроэнергию и записывает результат в файл:
pascalprogram CalculateElectricityCost; var ElectricityUsage, ElectricityCost: real; ElectricityFile: text; begin // Открываем файл для записи результата assign(ElectricityFile, 'ElectricityCost.txt'); rewrite(ElectricityFile); writeln('Введите количество кВт использованной электроэнергии:'); while not (eoln) do begin readln(ElectricityUsage); // Проверяем корректность ввода if ElectricityUsage < 0 then writeln('Ошибка: Количество кВт не может быть отрицательным.') else begin // Вычисляем стоимость if ElectricityUsage <= 100 then ElectricityCost := ElectricityUsage * 90 else if ElectricityUsage <= 500 then ElectricityCost := 100 * 90 + (ElectricityUsage - 100) * 168 else ElectricityCost := 100 * 90 + 400 * 168 + (ElectricityUsage - 500) * 224; // Выводим стоимость на экран и записываем в файл writeln('Стоимость оплаты за электроэнергию: ', ElectricityCost:0:2, ' коп.'); writeln(ElectricityFile, 'Стоимость оплаты за электроэнергию: ', ElectricityCost:0:2, ' коп.'); // Выходим из цикла ввода break; end; end; // Закрываем файл close(ElectricityFile); end.
Эта программа сначала открывает файл 'ElectricityCost.txt' для записи результата. Затем она запрашивает количество кВт использованной электроэнергии с клавиатуры, проверяет корректность ввода и вычисляет стоимость в соответствии с заданной схемой. Результат выводится на экран и записывается в файл.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili