Вопрос задан 28.06.2023 в 18:15. Предмет Информатика. Спрашивает Петров Стёпа.

СРОЧНО! Напишите программу,которая определяет длину ведённой строки и подсчитывает количество

букв «а»
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бакарюк Полина.

Если паскаль абс

program v1;

var st1:string;

   i,L:Integer;

   numA:Integer;

begin

   write('text: ');

   readln(st1);

   L := Length(st1);

   numA := 0;

   for i:=1 to L do begin

       case st1[i] of

           'А','а': numA:=numA+1; //rus

           'A','a': numA:=numA+1; //eng

       end;

   end;

   st1 := UpperCase(st1);

   writeln('Dlina stroki ',L);

   writeln('kol-vo A  ',numA);

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python, которая определяет длину введенной строки и подсчитывает количество букв "а":

python
# Получаем строку от пользователя input_string = input("Введите строку: ") # Определяем длину строки length = len(input_string) # Подсчитываем количество букв "а" (регистронезависимо) count_a = input_string.lower().count('а') # Выводим результаты print(f"Длина строки: {length}") print(f"Количество букв 'а': {count_a}")

Вы можете скопировать этот код и выполнить его в среде Python. Программа запросит вас ввести строку, а затем выведет длину строки и количество букв "а" в этой строке (регистронезависимо).

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос