Вопрос задан 28.06.2023 в 14:02. Предмет Информатика. Спрашивает Фадеева Виктория.

Используя цикл написать программу, которая выводит все числа Фибоначчи до 50 python​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сергеева Вероника.

Ответ:

first = 0

second = 1

print(first, second, end=" ")

for i in range(9):

   temp = second

   second += first

   first = temp

   print(second, end=" ")

Объяснение:

Не понял условия "до 50". Выводятся все числа Фибоначчи до 55, если необходим больше, то меняем значение "9" в цикле for.

first = 0  # Первое число Фибоначчи = 0

second = 1  # Второе число Фибоначчи = 1

print(first, second, end=" ")  # Выводим их

for i in range(9):  # Идём до 9

   temp = second  # Временная переменная = второму числу

   second += first  # Второе число = второе число + первое число

   first = temp  # Первое число = значению переменной temp

   print(second, end=" ") # Выводим

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Python, использующей цикл для вывода всех чисел Фибоначчи до 50:

python
def fibonacci(n): fib_list = [0, 1] while fib_list[-1] + fib_list[-2] <= n: fib_list.append(fib_list[-1] + fib_list[-2]) return fib_list fib_numbers = fibonacci(50) for num in fib_numbers: print(num)

В этом коде создается функция fibonacci, которая принимает параметр n (в данном случае, 50). Функция возвращает список всех чисел Фибоначчи, не превышающих n. Затем создается список fib_numbers с числами Фибоначчи до 50, и они выводятся с помощью цикла for.

Если вы запустите эту программу, она выведет следующий результат:

0 1 1 2 3 5 8 13 21 34
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос