Вопрос задан 28.06.2023 в 10:45.
Предмет Информатика.
Спрашивает Дулебенец Аня.
Напишите программу которая в массиве из 10 целых чисел определит кол-во четных чисел, кратных 5.
(Паскаль)Ответы на вопрос
Отвечает Мамонов Матвей.
Ответ:
var a:array[1..10] of integer;
i, c: integer;
begin
for i := 1 to 10 do read(a[i]);
c := 0;
for i := 1 to 10 do
if a[i] mod 10 = 0 then c := c + 1;
writeln(c)
end.
Объяснение:
Чётные числа, кратные 5 - это числа, которые делятся на 10, поэтому проверяем делимость на 10.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая определит количество четных чисел, кратных 5, в массиве из 10 целых чисел:
pascalprogram CountEvenMultiplesOf5; var numbers: array[1..10] of integer; i, count: integer; begin count := 0; // Инициализируем счетчик нулем // Заполняем массив числами writeln('Введите 10 целых чисел:'); for i := 1 to 10 do begin write('Число ', i, ': '); readln(numbers[i]); end; // Перебираем элементы массива и считаем четные числа, кратные 5 for i := 1 to 10 do begin if (numbers[i] mod 2 = 0) and (numbers[i] mod 5 = 0) then count := count + 1; end; writeln('Количество четных чисел, кратных 5, в массиве: ', count); end.
Эта программа сначала запрашивает у пользователя ввод 10 целых чисел и сохраняет их в массиве numbers. Затем она перебирает элементы массива и проверяет, являются ли они четными и кратными 5. Если условие выполняется, счетчик увеличивается на 1. По завершении цикла выводится количество найденных чисел.
Похожие вопросы
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
