написать программу в pascal, которая выводит числа из диапазона от 72 до 134, удовлетворяющие
условиям: 1. вывести все чётные числа; 2. вывести числа, оканчивающиеся на "3"; 3. вывести числа, сумма цифр которых меньше 11.Ответы на вопрос
Код программы:
var i, sum, a:integer;
begin
writeln('Четные числа:');
for i:= 72 to 134 do begin
if i mod 2 = 0 then
write(i, ' ');
end;
writeln();
writeln();
writeln('Числа, оканчивающиеся на "3":');
for i:= 72 to 134 do begin
if i mod 10 = 3 then
write(i, ' ');
end;
writeln();
writeln();
writeln('Числа, сумма цифр которых меньше 11:');
for i:= 72 to 134 do begin
a:= i;
sum:= 0;
while a <> 0 do begin
sum := sum + a mod 10;
a := a div 10;
end;
if sum < 11 then
write(i, ' ');
end;
end.
Вот пример программы на Pascal, которая выводит числа в диапазоне от 72 до 134 в соответствии с вашими условиями:
pascalprogram NumbersFilter; var num: integer; digitSum: integer; begin for num := 72 to 134 do begin // Условие 1: Вывести все чётные числа if num mod 2 = 0 then writeln('Чётное число: ', num); // Условие 2: Вывести числа, оканчивающиеся на "3" if num mod 10 = 3 then writeln('Число, оканчивающееся на "3": ', num); // Условие 3: Вывести числа, сумма цифр которых меньше 11 digitSum := 0; // Вычисляем сумму цифр числа var tempNum := num; while tempNum > 0 do begin digitSum := digitSum + (tempNum mod 10); tempNum := tempNum div 10; end; if digitSum < 11 then writeln('Число, сумма цифр которого меньше 11: ', num); end; end.
Эта программа пройдет по числам от 72 до 134 и выведет те, которые соответствуют вашим условиям.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
