Вопрос задан 27.06.2023 в 14:00. Предмет Информатика. Спрашивает Курамысова Назира.

Python. Напишите программу, которая приглашает по вводу десять цифр, добавляет их в список. На

экране выводит их сумму, максимальное и минимальное из них. Для нахождения сумм, максимума и минимума используйте встроенные функции Python sum () max () и min ().
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шпинь Егор.

Ответ:

list = []

for i in range(10):

   chk = False

   while chk == False:

       try:

           list.append(int(input("Введите " + str(i+1) + " число: ")))

           chk = True

       except ValueError:

           print("Неверное значение. Вводите целое число.")

print("Ваш массив: " + str(list))

print("Сумма чисел в массиве: " + str(sum(list)))

print("Минимальное число в массиве: " + str(min(list)))

print("Максимальное число в массиве: " + str(max(list)))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример Python программы, которая выполняет указанные действия:

python
# Создаем пустой список, в который будем добавлять введенные цифры numbers = [] # Просим пользователя ввести 10 цифр и добавляем их в список for i in range(10): try: num = int(input(f"Введите цифру {i+1}: ")) numbers.append(num) except ValueError: print("Ошибка: Введите цифру.") # Вычисляем сумму, максимум и минимум с использованием встроенных функций total = sum(numbers) maximum = max(numbers) minimum = min(numbers) # Выводим результаты print(f"Сумма введенных цифр: {total}") print(f"Максимальная цифра: {maximum}") print(f"Минимальная цифра: {minimum}")

Эта программа попросит пользователя ввести 10 цифр и затем вычислит сумму, максимум и минимум с использованием встроенных функций sum(), max() и min().

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос