Вопрос задан 27.06.2023 в 12:53.
Предмет Информатика.
Спрашивает Карапетян Арменчик.
Написать программу, заполняющую массив из 20 целочисленных элементов случайными числами в
диапазоне от 0 до 50 включительно ([0;50]) и подсчитывающую произведение чисел, кратных 2 и 3 одновременно. (ЯП- Турбо Паскаль)Ответы на вопрос
Отвечает Пак Максим.
Ответ:
Рада была помочь♡
Удачи тебе!)
Объяснение:
var k,sum:integer;
begin
sum:=0;
for k:=0 to 50 do
if(k mod 3 =0) then sum:=sum+k;
writeln(sum);
end.
Вроде так
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на языке Turbo Pascal, которая заполняет массив из 20 целочисленных элементов случайными числами в диапазоне от 0 до 50 включительно и подсчитывает произведение чисел, кратных 2 и 3 одновременно:
pascalprogram Multiply2And3; var arr: array[1..20] of integer; i, product: integer; begin randomize; // Инициализация генератора случайных чисел // Заполняем массив случайными числами от 0 до 50 for i := 1 to 20 do arr[i] := random(51); // Генерация случайного числа от 0 до 50 // Инициализируем произведение product := 1; // Вычисляем произведение чисел, кратных 2 и 3 одновременно for i := 1 to 20 do begin if (arr[i] mod 2 = 0) and (arr[i] mod 3 = 0) then product := product * arr[i]; end; // Выводим результат на экран writeln('Массив случайных чисел:'); for i := 1 to 20 do write(arr[i], ' '); writeln; writeln('Произведение чисел, кратных 2 и 3 одновременно: ', product); readln; end.
Эта программа создает массив из 20 случайных чисел в диапазоне от 0 до 50, затем вычисляет произведение чисел, кратных 2 и 3 одновременно, и выводит результат на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
