Вопрос задан 27.06.2023 в 11:01.
Предмет Информатика.
Спрашивает Салмин Илья.
Написать программу, результатом которой является число кратное 3. поиск осуществляем из массива в
20 чисел (числа от -20 до 20) PascalОтветы на вопрос
Отвечает Мальцев Никита.
Ответ:
program z1;
var a: array [1..20] of integer;
i,k,ch: integer;
begin
randomize;
k:=0;
ch:=0;
write('Массив: ');
for i := 1 to 20 do
begin
a[i] := random(41) - 20;
write(a[i],' ');
if a[i] mod 3 = 0 then
begin
k:=1;
ch:=a[i]
end
end;
writeln;
if k=0 then write('В массиве нет чисел, кратных 3')
else write('Число кратное 3: ',ch)
end.
Объяснение:
Число 0 кратно любому натуральному числу
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая находит число в массиве из 20 чисел (от -20 до 20) и выводит первое найденное число, которое кратно 3:
pascalprogram FindMultipleOf3; var numbers: array[1..20] of integer; i: integer; begin // Заполнение массива случайными числами от -20 до 20 randomize; for i := 1 to 20 do numbers[i] := random(41) - 20; // Поиск числа, кратного 3 for i := 1 to 20 do begin if numbers[i] mod 3 = 0 then begin writeln('Первое число, кратное 3, в массиве: ', numbers[i]); break; // Выход из цикла после нахождения первого числа end; end; readln; end.
Эта программа создает массив из 20 случайных чисел от -20 до 20 и затем ищет первое число, кратное 3, в этом массиве. Если такое число найдено, оно выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
