Вопрос задан 27.06.2023 в 01:35. Предмет Информатика. Спрашивает Асланян Иван.

Сумма цифр. Напишите программу, которая вычисляет суммуцифр трехзначного числа.Пример

1Ввод:175Вывод:13(в Python 3)​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ракова Альбина.

a = 175

a = list(str(a))

summa = 0

for i in a:

   summa += int(i)

print(summa)

------ Либо если явно 3 цифры

a = 175

a = list(str(a))

print(int(a[0]) + int(a[1]) + int(a[2]))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете написать программу для вычисления суммы цифр трехзначного числа на Python 3 следующим образом:

python
# Получаем трехзначное число от пользователя num = int(input("Введите трехзначное число: ")) # Проверяем, что число действительно трехзначное if 100 <= num <= 999: # Вычисляем сумму цифр digit1 = num // 100 digit2 = (num % 100) // 10 digit3 = num % 10 digit_sum = digit1 + digit2 + digit3 # Выводим результат print("Сумма цифр:", digit_sum) else: print("Пожалуйста, введите трехзначное число.")

Эта программа запрашивает у пользователя трехзначное число, вычисляет сумму его цифр и выводит результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос