Вопрос задан 27.06.2023 в 00:54. Предмет Информатика. Спрашивает Бабаев Эльтун.

Напишите программу,которая предлагает ввести пароль и не переходит к выполнению основной части,пока

не введён правильный пароль. Основная часть-вывод на экран «секретных данных». Помогите пожалуйста
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Романова Софья.

pasw = "123"

def menu():

   while 1:

       if password(input("Введите пароль: ")) == True:

           print("Пароль верный")

           break

       else:

           print("Неверный пароль")

   a = 1

   d = 2

   print(a+d)

def password(passw):

   if passw == pasw:

       return 1

   else:

       return 0

menu()


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая реализует вашу задачу:

python
# Задаем правильный пароль правильный_пароль = "мойсекретныйпароль" # Просим пользователя ввести пароль и продолжаем цикл до ввода правильного пароля while True: введенный_пароль = input("Введите пароль: ") # Проверяем, совпадает ли введенный пароль с правильным if введенный_пароль == правильный_пароль: print("Доступ разрешен. Секретные данные: ...") break else: print("Неправильный пароль. Попробуйте снова.")

Этот код будет запрашивать пароль у пользователя и продолжать запрашивать его, пока не будет введен правильный пароль. После ввода правильного пароля он выведет "Доступ разрешен" и секретные данные.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос