Вопрос задан 26.06.2023 в 22:25. Предмет Информатика. Спрашивает Киричек Андрей.

Информатика паскаль!!! Здравствуйте! Не могли вы помочьНужно написать программу, которая

посчитает количество трехзначных чисел кратных четырём. Чисел изначально n. (через for)​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Маслов Артем.

var

 n, count, i: integer;

begin

 count := 0;

 write('Введите трехзначное число n: ');

 readln(n);

 if ((n < 100) or (n > 999)) then

   writeln(' Число не трехзначное!')

 else

 begin

   begin

     for i := 100 to n do

       if i mod 4 = 0 then count := count + 1;

   end;

   writeln(' Количество трехзначных чисел кратных четырем = ', count);

 end;

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке программирования Pascal, которая будет считать количество трехзначных чисел, кратных четырём. Для этой задачи мы можем использовать цикл for. Вот пример программы:

pascal
program CountMultiplesOfFour; var n, count, i: integer; begin // Запрашиваем у пользователя число n write('Введите значение n: '); readln(n); // Инициализируем счетчик нулем count := 0; // Проходим через числа от 100 до n for i := 100 to n do begin // Проверяем, является ли текущее число кратным четырём if (i mod 4 = 0) then count := count + 1; end; // Выводим результат writeln('Количество трехзначных чисел, кратных четырём: ', count); // Ждем, пока пользователь нажмет клавишу Enter, перед завершением программы readln; end.

Эта программа сначала запрашивает у пользователя значение n, затем использует цикл for, чтобы перебирать числа от 100 до n. Для каждого числа, она проверяет, делится ли оно на четыре без остатка (i mod 4 = 0) и увеличивает счетчик count, если условие выполняется. В конце программа выводит количество трехзначных чисел, кратных четырём.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос