Вопрос задан 26.06.2023 в 19:38. Предмет Информатика. Спрашивает Панкова Софья.

( Python ) Напишите программу, которая заполняет массив из 20 элементов случайными числами на

отрезке [-10;10] и находит:1) Отдельно сумму элементов в первой и во второй половинах массива.2)Произведение ненулевых элементов3) Количество отрицательных элементов массива
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ткаченко Софья.

Ответ:

from random import randint

# заполняем массив случайными числами

arr = [randint(-10,10) for i in range(20)]

print(arr)

# задание 1

print(f'Сумма элементов первой половины массива {arr[0:10]} равна {sum(arr[0:10])}')

print(f'Сумма элементов второй половины массива {arr[10:20]} равна {sum(arr[10:20])}')

# задание 2

k=1

for i in arr:

   if i!=0:

       k*=i

print(f'Произведение ненулевых элементов массива равно {k}')

# задание 3

k=0

for i in arr:

   if i<0:

       k+=1

print(f'Количество отрицательных элементов массива равно {k}')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете выполнить это задание, используя модуль random для генерации случайных чисел в заданном диапазоне. Вот Python-программа, которая делает то, что вы запросили:

python
import random # Создаем пустой массив из 20 элементов arr = [] # Заполняем массив случайными числами на отрезке [-10;10] for _ in range(20): arr.append(random.randint(-10, 10)) # Выводим массив print("Случайный массив:", arr) # 1) Сумма элементов в первой и второй половинах массива halfway = len(arr) // 2 first_half_sum = sum(arr[:halfway]) second_half_sum = sum(arr[halfway:]) print("Сумма элементов в первой половине:", first_half_sum) print("Сумма элементов во второй половине:", second_half_sum) # 2) Произведение ненулевых элементов non_zero_elements = [x for x in arr if x != 0] product_of_non_zero_elements = 1 for elem in non_zero_elements: product_of_non_zero_elements *= elem print("Произведение ненулевых элементов:", product_of_non_zero_elements) # 3) Количество отрицательных элементов массива negative_count = len([x for x in arr if x < 0]) print("Количество отрицательных элементов:", negative_count)

Этот код создает массив, заполняет его случайными числами, а затем выполняет указанные вами операции.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос