Вопрос задан 26.06.2023 в 19:10. Предмет Информатика. Спрашивает Смагулов Медя.

1. Напишите программу, которая при введении порядко вого номера пальца руки выводит его название

на экране.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рябов Артём.

C#

int a;

           ConsoleKeyInfo keyInfo;

           do

           {

               Console.WriteLine("Введении один порядковый номера пальца руки:\n1, 2, 3, 4, 5");

               a = Convert.ToInt32(Console.ReadLine());

               switch (a)

               {

                   case 1:

                       Console.WriteLine("Большой\n");

                       break;

                   case 2:

                       Console.WriteLine("Указательный\n");

                       break;

                   case 3:

                       Console.WriteLine("Средний\n");

                       break;

                   case 4:

                       Console.WriteLine("Безымянный\n");

                       break;

                   case 5:

                       Console.WriteLine("Мизинец\n");

                       break;

                   default:

                       Console.WriteLine("Такого пальца нет\n");

                       break;

               }    

               

               Console.WriteLine("Если хотите повторить программу нажмите F");

               Console.WriteLine("Если хотите завершить программу нажмите любую другую кнопку\n");

               keyInfo = Console.ReadKey(true);

           }

           while (keyInfo.Key == ConsoleKey.F);


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для написания программы, которая будет выводить название пальца руки на основе введенного порядкового номера, вы можете использовать Python. Вот пример такой программы:

python
# Запросить у пользователя порядковый номер пальца ordinal_number = int(input("Введите порядковый номер пальца (1-5): ")) # Создать список с названиями пальцев fingers = ["Большой палец", "Указательный палец", "Средний палец", "Безымянный палец", "Мизинец"] # Проверить, что введенный номер находится в диапазоне от 1 до 5 if 1 <= ordinal_number <= 5: # Вывести название пальца на экран print("Палец номер", ordinal_number, "называется", fingers[ordinal_number - 1]) else: print("Некорректный ввод. Порядковый номер должен быть от 1 до 5.")

Эта программа сначала запрашивает у пользователя порядковый номер пальца. Затем она использует список fingers, чтобы получить название пальца по введенному номеру (учитывая, что индексы в списке начинаются с 0, мы вычитаем 1 из введенного номера). Наконец, программа выводит название пальца на экран.

Вы можете скопировать этот код и выполнить его в своей среде разработки Python.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос