Вопрос задан 26.06.2023 в 15:57. Предмет Информатика. Спрашивает Путилина Анастасия.

Напишите программу для выполнения перестановки первого нечетного и первого отрицательного элементов

массива​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бурёнин Богдан.

Ответ:

#Python 3.8.3

from typing import *

def FindFirstIndex(source: Iterable[Any], predicate: Callable[[Any], Any]):

   for index, item in enumerate(source):

       if (predicate(item)):

           return index

def main():

   arr = [1, 2, 3, 4, 5, -1, 2, -4]

   firstOdd = FindFirstIndex(arr, lambda p: p % 2 != 0)

   firstNegative = FindFirstIndex(arr, lambda p: p < 0)

   arr[firstOdd], arr[firstNegative] = arr[firstNegative], arr[firstOdd]

   print(arr)

if __name__ == '__main__':

   main()

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python для выполнения перестановки первого нечетного и первого отрицательного элементов в массиве:

python
def swap_first_odd_negative(arr): # Ищем индекс первого нечетного элемента odd_index = -1 for i in range(len(arr)): if arr[i] % 2 != 0: odd_index = i break # Ищем индекс первого отрицательного элемента negative_index = -1 for i in range(len(arr)): if arr[i] < 0: negative_index = i break # Если найдены оба элемента, выполняем перестановку if odd_index != -1 and negative_index != -1: arr[odd_index], arr[negative_index] = arr[negative_index], arr[odd_index] else: print("Не удалось найти нечетный и отрицательный элементы для перестановки") return arr # Пример использования arr = [3, -2, 5, 1, 4, -6] result = swap_first_odd_negative(arr) print(result)

Эта программа ищет первый нечетный и первый отрицательный элементы в массиве и выполняет их перестановку, если оба элемента найдены.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос