напишите программу которая в последовательности 20 целых чисел определяет их количество и сумму
чётных чисел до первого введеного нуля ПАСКАЛЬ ПРОСТАЯ СХЕМАОтветы на вопрос
Ответ:
pascal
Объяснение:
var
i, kol, summ: integer;
a: array[1..20] of integer;
begin
WriteLn('Введите 20 целых чисел: ');
for i := 1 to 20 do
begin
Write('a[', i, '] = ');
ReadLn(a[i]);
end;
for i := 1 to 20 do
if a[i] <> 0 then
begin
if a[i] mod 2 = 0 then
begin
inc(kol);
summ := summ + a[i];
end;
end
else break;
WriteLn('Количество четных чисел до первого нуля равно ', kol);
WriteLn('Их сумма равна ', summ);
end.
Вот пример программы на Pascal, которая выполняет задачу определения количества и суммы четных чисел в последовательности из 20 целых чисел до первого введенного нуля:
pascalprogram CountEvenNumbers; var i, num, count, sum: integer; begin count := 0; sum := 0; writeln('Введите последовательность из 20 целых чисел:'); for i := 1 to 20 do begin readln(num); if num = 0 then break; // Выход из цикла, если введен ноль if num mod 2 = 0 then begin count := count + 1; sum := sum + num; end; end; writeln('Количество четных чисел: ', count); writeln('Сумма четных чисел: ', sum); end.
Программа просит пользователя ввести 20 целых чисел и останавливается, если введен ноль или после ввода 20 чисел. Она подсчитывает количество и сумму четных чисел и выводит результаты на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
