Вопрос задан 25.06.2023 в 21:42. Предмет Информатика. Спрашивает Гвоздик Кузьма.

СРОЧНО!! Написать программу на языке программирования Паскаль: Автобусный билет считают

счастливым, если сумма трех первых цифр билета равна сумме трех последних цифр.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лис Илья.

Ответ:

Программа:

var n,a1,a2,s1,s2:integer;

begin

write('n = '); readln(n);

a1:=n div 1000;

s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);

a2:=n mod 1000;

s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);

if s1=s2 then writeln('Билет счастливый')

          else writeln('Билет не счастливый')

end.

Пример:

n = 123231

Билет счастливый

Блок-схема - в прилагаемом файле.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке программирования Паскаль, которая проверяет, является ли автобусный билет счастливым:

pascal
program HappyBusTicket; var ticketNumber, digit, firstHalfSum, secondHalfSum: integer; begin // Введите номер автобусного билета writeln('Введите номер автобусного билета (шестизначное число): '); readln(ticketNumber); // Проверяем, что номер билета состоит из 6 цифр if (ticketNumber < 100000) or (ticketNumber > 999999) then begin writeln('Номер билета должен быть шестизначным числом.'); exit; end; // Инициализируем суммы первой и второй половин билета firstHalfSum := 0; secondHalfSum := 0; // Разбиваем номер билета на цифры и считаем суммы for var i := 1 to 6 do begin digit := ticketNumber mod 10; ticketNumber := ticketNumber div 10; if i <= 3 then firstHalfSum := firstHalfSum + digit else secondHalfSum := secondHalfSum + digit; end; // Проверяем, является ли билет счастливым if firstHalfSum = secondHalfSum then writeln('Этот билет счастливый!') else writeln('Этот билет несчастливый.'); end.

Просто скопируйте этот код в среду разработки Pascal и запустите программу. Она попросит вас ввести номер автобусного билета, а затем сообщит, счастливый ли этот билет или нет, основываясь на сумме его цифр.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос