Вопрос задан 25.06.2023 в 21:27. Предмет Информатика. Спрашивает Романова Софья.

СРОЧНО! ПОМОГИТЕ Задача 1. Напишите программу используя команды append и remov Задача 2. Вывести

первый и последний элемент списка. names = [ 386, 462, 47, 418, 907, 344, 236, 375, 823, 566, 597, 978, 328, 615, 953, 345, 399, 162, 758, 219, 918, 237, 412, 566, 826, 248, 866, 950, 626, 949, 687, 217 ] Задача 3 . Написать код программы которая выводит число элементов списка Задача 4. Напишите программу которая соединяет строки 3 переменных (конкатенация) Задача 5. Напишите программу, которая принимает два списка и выводит все элементы второго, которых нет во первом Задача 6. Посчитайте, сколько раз символ "и" встречается в строке. 'Напишите программу, которая находит самую большую сумму'
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Михайлов Ждан.

Ответ:

1)

names = []

name = input()

names.append(name)

print('Имя успешно добавлено! Если хотите его удалить, введите - 1')

choice = int(input())

if choice == 1:

    names.remove(name)

2) print(names[0], names[-1])

3) print(len(names)) # names - ваш список.

4)

a = 'При'

b = 'ве'

c = 'т'

print(a + b + c)

5)

set_1 = set(['1', '2', '3'])

set_2 = set(['1', '7'])

print(set_2 - set_1)

6)

text = 'Напишите программу, которая находит самую большую сумму'

print(text.count('и'))

Объяснение:

len - находит длину.

count - Возвращает количество элементов со значением...

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Давайте по очереди решим каждую из ваших задач:

Задача 1:

python
names = [386, 462, 47, 418, 907, 344, 236, 375, 823, 566, 597, 978, 328, 615, 953, 345, 399, 162, 758, 219, 918, 237, 412, 566, 826, 248, 866, 950, 626, 949, 687, 217] # Добавление элемента в список names.append(123) # Удаление элемента из списка if 567 in names: names.remove(567) print(names)

Задача 2:

python
names = [386, 462, 47, 418, 907, 344, 236, 375, 823, 566, 597, 978, 328, 615, 953, 345, 399, 162, 758, 219, 918, 237, 412, 566, 826, 248, 866, 950, 626, 949, 687, 217] # Вывод первого и последнего элемента списка first_element = names[0] last_element = names[-1] print("Первый элемент:", first_element) print("Последний элемент:", last_element)

Задача 3:

python
names = [386, 462, 47, 418, 907, 344, 236, 375, 823, 566, 597, 978, 328, 615, 953, 345, 399, 162, 758, 219, 918, 237, 412, 566, 826, 248, 866, 950, 626, 949, 687, 217] # Вывод числа элементов в списке num_elements = len(names) print("Число элементов в списке:", num_elements)

Задача 4:

python
# Соединение строк из трех переменных (конкатенация) string1 = "Hello, " string2 = "world!" string3 = " How are you?" result_string = string1 + string2 + string3 print(result_string)

Задача 5:

python
# Программа, которая принимает два списка и выводит все элементы второго, которых нет в первом list1 = [1, 2, 3, 4, 5] list2 = [3, 4, 5, 6, 7] result_list = [item for item in list2 if item not in list1] print(result_list)

Задача 6:

python
# Посчитать, сколько раз символ "и" встречается в строке text = 'Напишите программу, которая находит самую большую сумму' count_i = text.count('и') print("Количество символов 'и' в строке:", count_i)

Эти программы выполняют задачи, описанные в вашем вопросе. Вы можете скопировать их код и выполнить в среде Python для получения результатов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос