Вопрос задан 25.06.2023 в 16:17. Предмет Информатика. Спрашивает Гаврилюк Влада.

Напишите программу, которая вводит символьную строку и определяет, сколько раз в ней встречается

буква «Ю». Пример: Введите строку: АЮАЮАЮЮ Букв "Ю": 4
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Зяблицев Дима.

Ответ:

const p='юЮ';  

var s:string; i,n:integer;  

begin  

writeln('Текст: '); n:=0; readln(s);  

for i:=1 to length(s) do if pos(s[i],p)<>0 then inc(n);  

writeln(n); readln  

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая считает количество букв "Ю" в введенной строке:

python
# Вводим строку с клавиатуры input_string = input("Введите строку: ") # Используем метод count() для подсчета количества букв "Ю" (как заглавных, так и строчных) count_of_ю = input_string.lower().count("ю") # Выводим результат print(f'Букв "Ю": {count_of_ю}')

Эта программа сначала приводит введенную строку к нижнему регистру с помощью lower(), чтобы учесть буквы "Ю" независимо от их регистра, а затем использует метод count() для подсчета количества букв "ю" в строке.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос