Пожалуйста гении паскаля, 100 баллов даю! 1. Вводятся годы рождения двух детей. Определите
старшего из них. 2. В школу танцев принимаются юноши и девушки, имеющие рост не ниже 168 см. и не выше 173 см. Их вес должен соотноситься с ростом по формуле: значение веса <= значения роста минус 115. Определите, будет ли поступающий принят в школу.Ответы на вопрос
1)
var g1,g2:integer;
begin
writeln('Введите годы рождения двух детей');
readln(g1,g2);
if g1<g2 then
writeln('Старший ребенок родился в ',g1,'году')
else
writeln('Старший ребенок родился в ',g2,'году');
end.
2)
var r,v,ves:real;
begin
write('Введите рост ');
readln(r);
writeln('Введите вес ');
readln(ves);
v:=r-115;
if (r>=168) and (r<=173) then
if v=ves then
writeln('Поступающий будет принят в школу')
else
writeln('Поступающий не будет принят')
else
writeln('Поступающий не будет принят');
end.
Для решения этих задач вам потребуется написать программу на языке программирования, так как они требуют выполнения конкретных вычислений. Вот пример решения этих задач на языке Python:
- Определение старшего из двух детей:
python# Вводим годы рождения детей
год_рождения_1 = int(input("Введите год рождения первого ребенка: "))
год_рождения_2 = int(input("Введите год рождения второго ребенка: "))
# Определяем старшего ребенка
if год_рождения_1 > год_рождения_2:
print("Первый ребенок старше.")
elif год_рождения_1 < год_рождения_2:
print("Второй ребенок старше.")
else:
print("Оба ребенка родились в один год.")
- Определение, будет ли поступающий принят в школу танцев:
python# Вводим рост и вес поступающего
рост = float(input("Введите рост поступающего (в см): "))
вес = float(input("Введите вес поступающего (в кг): "))
# Проверяем условия для поступления
if 168 <= рост <= 173 and вес <= рост - 115:
print("Поступающий принят в школу танцев.")
else:
print("Поступающий не принят в школу танцев.")
Вы можете скопировать код и выполнить его в среде программирования Python, чтобы получить ответы на обе задачи.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
