Вопрос задан 24.06.2023 в 06:08. Предмет Информатика. Спрашивает Перро Лера.

СЕРЕДОВИЩЕ ВИКОНАННЯ: Pyton Створіть програму для обчислення кількості парних елементів усписку,

заповненого випадковими числами.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шапель Милана.

Ответ:

n = int(input('введите количество элементов списка '))

mass = [int(input('введите элемент списка ')) for j in range(n)]

k = 0

for i in mass:

  if i % 2 == 0:

      k += 1

print(mass)

print('Количество парных чисел ', k)

Объяснение:

from random import randint

n = int(input('введите количество элементов списка '))

mass = [randint(1, 100) for j in range(n)]

k = 0

for i in mass:

  if i % 2 == 0:

      k += 1

print(mass)

print('Количество парных чисел ', k)

0 0
Отвечает Назиров Нихад.

Ответ:

Вариант 1, где пользователь вводит нужное количество, а числа генерируются случайно:

import random

elements = [] # создаём пустой список, куда будут записываться введенные числа

# спрашиваем пользователя сколько чисел необходимо

numbersCount = int(input('Сколько чисел желаете сгенерировать: '))

for i in range(numbersCount): # запускаем цикл столько раз, сколько запросил пользователь

   elements.append(random.randrange(1,100)) # наполняем elements случайным числом

evenNumbersCounter = 0 # счётчик чётных чисел

for element in elements:

   if element % 2 == 0:

       evenNumbersCounter += 1

print(f'Числа: {elements}')

print(f'Количество четных чисел: {evenNumbersCounter}')

Вариант 2, где пользователь сам вводит 20 чисел:

elements = [] # создаём пустой список, куда будут записываться введенные числа

# цикл 20 раз спрашивает числа у пользователя и записывает их в elements преобразовывая в int

for i in range(1,21): #

   elements.append(int(input(f'#{i} Введите число: ')))

evenNumbersCounter = 0 # создаем счётчик, куда далее будем считать количество четных чисел

for element in elements:

   if element % 2 == 0:

       evenNumbersCounter += 1

       # увеличиваем счётчик, если у числа нет остатка при делении на 2 (то есть, число чётное)

print(f'Количество четных чисел: {evenNumbersCounter}')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Ось приклад програми на мові Python, яка обчислює кількість парних елементів у списку, заповненому випадковими числами. Для генерації випадкових чисел використовується модуль random:

python
import random # Генеруємо випадковий список з 10 елементів (ви можете змінити розмір списку) random_numbers = [random.randint(1, 100) for _ in range(10)] print("Випадковий список:", random_numbers) # Лічильник для підрахунку парних елементів even_count = 0 # Перебираємо всі елементи списку і підраховуємо парні for number in random_numbers: if number % 2 == 0: even_count += 1 print("Кількість парних елементів у списку:", even_count)

У цьому прикладі ми генеруємо випадковий список random_numbers, який містить 10 цілих чисел в діапазоні від 1 до 100. Потім ми перебираємо цей список і використовуємо операцію % для визначення, чи є число парним (якщо залишок від ділення на 2 дорівнює 0). Кількість парних чисел підраховується та виводиться на екран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос