Вопрос задан 04.07.2018 в 06:06.
Предмет Информатика.
Спрашивает Кусайко Александр.
Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов,
используя подпрограмму вычисления площади круга(два варианта:с процедурой и с функцией)Ответы на вопрос
Отвечает Каширских Даниил.
Var
r1, r2: real;
procedure pCircleSquare(r: real; var S: real);
begin
s := Pi * sqr(r);
end;
function fCircleSquare(r: real): Real;
begin
fCircleSquare := Pi * sqr(r);
end;
begin
Write('r1, r2 = ');
ReadLn(r1, r2);
writeln('Функция S = ', abs(fCircleSquare(r1) - fCircleSquare(r2)):5:2);
pCircleSquare(r1, r1);
pCircleSquare(r2, r2);
writeln('Процедура S = ', abs(r1 - r2):5:2);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
