Вопрос задан 24.06.2023 в 03:48. Предмет Информатика. Спрашивает Сурмай Артём.

Задание Python 2_6: Найдите все трѐхзначные и четырѐхзначные числа Армстронга.Число Армстронга.

Числом Армстронга считается натуральное число, сумма цифр которого, возведенных в N-ную степень (N – количество цифр в числе) равна самому числу.Например, 153 = 13 + 53 + 33.Задание Python 2_7:Напишите программу, которая запрашивает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.Автоморфным называется натуральное число, если оно равно последним цифрам своего квадрата. Например, 252 = 625.rint ("всё!")Задание Python 4: Составить программу для вычисления среднего арифметического N произвольных вводимых чисел.Задание Python 5: Исправить предыдущее задание (2_4) для работы со случайными числами.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рудакова Ирина.

Ответ:Задание 4

summ, n = 0, int(input())

for _ in range (n):

   summ += int(input())

float(summ)

print(summ / n)

Задание 5

summ, n = 0, int(input())

from random import randint

for _ in range (n):

   summ += randint(0, 100)

float(summ)

print(summ / n)

Задание 2_6

for i in range(100,1000):

   sum = 0

   for s in range(0, 3):

       i = str(i)

       sum = sum + int(i[s]) ** 3

       i = int(i)

   if sum == i:

       print(i)

Задание 2_7

n = int(input())

for i in range(n):

   if i * i % (10 ** len(str(i))) == i :

       print(i)

Объяснение:

В задании 5, в "random.randint(0,100)" необзательно эти числа, спроси у учителя какой должен быть интервал(тут от 0 до 100) и впиши нужные числа

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задание Python 2_6: Поиск чисел Армстронга.

python
def is_armstrong(number): n = len(str(number)) total = 0 temp = number while temp > 0: digit = temp % 10 total += digit ** n temp //= 10 return total == number armstrong_numbers = [] for number in range(100, 10000): if is_armstrong(number): armstrong_numbers.append(number) print("Трёхзначные и четырёхзначные числа Армстронга:") print(armstrong_numbers)

Задание Python 2_7: Поиск автоморфных чисел.

python
def is_automorphic(number): square = number ** 2 str_number = str(number) str_square = str(square) return str_square.endswith(str_number) n = int(input("Введите натуральное число N: ")) automorphic_numbers = [] for number in range(1, n + 1): if is_automorphic(number): automorphic_numbers.append(number) print("Автоморфные числа не превосходящие", n, "составляют:") print(automorphic_numbers)

Задание Python 4: Вычисление среднего арифметического N произвольных чисел.

python
n = int(input("Введите количество чисел N: ")) total = 0 for i in range(n): num = float(input("Введите число: ")) total += num average = total / n print("Среднее арифметическое введенных чисел:", average)

Задание Python 5: Исправление предыдущего задания для работы со случайными числами.

python
import random n = int(input("Введите количество случайных чисел N: ")) total = 0 for i in range(n): num = random.uniform(1, 100) # Генерация случайного числа в интервале [1, 100] total += num average = total / n print("Среднее арифметическое случайных чисел:", average)

Эти программы выполняют указанные задачи. Задание Python 2_6 и 2_7 находят числа Армстронга и автоморфные числа соответственно, задание Python 4 и 5 вычисляют среднее арифметическое чисел, где задание 5 использует случайные числа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос