Вопрос задан 24.06.2023 в 00:47. Предмет Информатика. Спрашивает Федоров Степан.

Напишите программу, которая заполняет элементы квадратной матрицы, размером NхN элементов, лежащие

ниже побочной диагонали значением -1, а остальные увеличивает на 1. Матрицу изначально надо заполнить случайными числами в интервале [10,90]. Число N вводится с клавиатуры.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Нухтархан Айгерім.

Ответ:

from random import randint

n = int(input())

arr = [[randint(10, 90) for j in range(n)] for i in range(n)]

print('\n'.join([' '.join([str(i) for i in row]) for row in arr]), '\n')

arr = [[arr[i][j] + 1 if i <= n - 1 - j else -1 for j in range(n)] for i in range(n)]

print('\n'.join([' '.join([str(i) for i in row]) for row in arr]))

Объяснение:

или такое заполнение

from random import randint

n = int(input())

arr = [[randint(10, 90) for j in range(n)] for i in range(n)]

print('\n'.join([' '.join([str(i) for i in row]) for row in arr]), '\n')

for i in range(n):

   for j in range(n):

       if i <= n - 1 - j:

           arr[i][j] += 1

       else:

           arr[i][j] = -1

print('\n'.join([' '.join([str(i) for i in row]) for row in arr]))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для создания программы, которая выполняет описанные вами действия, можно использовать язык программирования Python. Вот пример программы:

python
import random # Ввод размера матрицы N с клавиатуры N = int(input("Введите размер матрицы N: ")) # Инициализация матрицы случайными числами от 10 до 90 matrix = [[random.randint(10, 90) for _ in range(N)] for _ in range(N)] # Вывод исходной матрицы print("Исходная матрица:") for row in matrix: print(row) # Обработка матрицы for i in range(N): for j in range(N): if i + j < N - 1: matrix[i][j] += 1 else: matrix[i][j] = -1 # Вывод обработанной матрицы print("Обработанная матрица:") for row in matrix: print(row)

Эта программа сначала создает матрицу размером N x N, заполняя ее случайными числами в интервале [10, 90]. Затем она обходит элементы матрицы и увеличивает значения элементов выше побочной диагонали на 1, а элементы ниже побочной диагонали устанавливает в -1. Наконец, программа выводит исходную и обработанную матрицы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос