Вопрос задан 23.06.2023 в 21:53. Предмет Информатика. Спрашивает Ибрагимова Динара.

ПОМОГИТЕ С КОДОМ НА PYTHON! Задача1. Количество элементов между минимумом и максимумом Написать

программу, которая для 10 целочисленных элементов определяет, сколько положительных элементов располагается между максимальным и минимальным элементами. Задача2. Сумма элементов правее последнего отрицательного Написать программу, которая для n вещественных элементов определяет сумму элементов, расположенных правее последнего отрицательного элемента. Задача3. Сжатие массива Написать программу, которая «сжимает» целочисленный массив из 10 элементов, удаляя из него элементы, меньшие заданной величины.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тихонов Денис.

1:

from random import randint

cnt = 0

values = [randint(-50, 50) for _ in range(10)]

min_index = values.index(min(values))

max_index = values.index(max(values))

if max_index < min_index: min_index, max_index = max_index, min_index

for i in range(min_index+1,max_index):

   if values[i] > 0: cnt += 1

print(values)

print('Количество положительных значений между минимальным и максимальным значениями равно:', cnt)

2:

from random import randint

summ = 0

n = int(input('Введите количество значений в массиве: '))

values = [randint(-500, 500)/100 for _ in range(n)]

for value in values[::-1]:

   if value < 0: break

   summ += value

print(values)

print('Сумма значений правее последнего отрицательного значения равна:', summ)

3.

from random import randint

values = [randint(-50, 50) for _ in range(10)]

print(values)

n = int(input('Введите значение, элементы меньше которого будут удалены: '))

for i in range(len(values)-1, 0, -1):

   if values[i] < n: values.pop(i)

print(values)

0 0
Отвечает Башлыкова Оля.

1)

mas = [1, 2, -2, 3, -5, 12, 5]  # Можете указать свои числа

start = mas.index(max(mas))

stop = max.index(min(mas))

if start > stop:

   start, stop = stop, start

print(len(list(filter(lambda x: x > 0, mas[start+1:stop]))))

2)

mas = [1, 2, -2, 3, -5, 12, 5]  # Можете указать свои числа

print(sum(mas[-mas[::-1].index(list(filter(lambda x: x < 0, mas))[-1]):]))

3)

mas = [1, 2, -2, 3, -5, 12, 5]  # Можете указать свои числа

minimum = 1  # Все значения меньше указанного будут удалены

mas = list(filter(lamda x: x >= minimum, mas))

print(*mas)  # Выводи получившийся массив

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, помогу! Давай начнем с первой задачи:

Задача 1: Количество элементов между минимумом и максимумом

python
# Вводим 10 целочисленных элементов elements = [int(input(f"Введите элемент {i + 1}: ")) for i in range(10)] # Находим индексы минимума и максимума min_index = elements.index(min(elements)) max_index = elements.index(max(elements)) # Определяем диапазон между минимумом и максимумом if min_index < max_index: range_between = elements[min_index + 1:max_index] else: range_between = elements[max_index + 1:min_index] # Фильтруем положительные элементы positive_elements = [x for x in range_between if x > 0] # Выводим результат print(f"Количество положительных элементов между минимумом и максимумом: {len(positive_elements)}")

Просто вставь этот код в свою программу, и он должен решить первую задачу. Теперь переходим ко второй задаче:

Задача 2: Сумма элементов правее последнего отрицательного

python
# Вводим n вещественных элементов n = int(input("Введите количество элементов: ")) elements = [float(input(f"Введите элемент {i + 1}: ")) for i in range(n)] # Находим индекс последнего отрицательного элемента last_negative_index = max((i for i, x in enumerate(elements) if x < 0), default=-1) # Считаем сумму элементов правее последнего отрицательного sum_right_of_last_negative = sum(elements[last_negative_index + 1:]) # Выводим результат print(f"Сумма элементов правее последнего отрицательного: {sum_right_of_last_negative}")

Теперь последняя задача:

Задача 3: Сжатие массива

python
# Вводим целочисленный массив из 10 элементов array = [int(input(f"Введите элемент {i + 1}: ")) for i in range(10)] # Вводим заданное значение threshold = int(input("Введите заданное значение: ")) # Сжимаем массив, удаляя элементы меньше заданного значения compressed_array = [x for x in array if x >= threshold] # Выводим результат print("Сжатый массив:", compressed_array)

Просто добавь этот код к своей программе, и он решит третью задачу. Если у тебя возникнут вопросы или нужна дополнительная помощь, дай знать!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос