Вопрос задан 23.06.2023 в 12:16.
Предмет Информатика.
Спрашивает Пакин Рома.
Напишите программу на языке паскаль , которая будет делииь пирог на равные части по весу. ( масса
пирога/кол во учеников ) Если кол во учеников = 0 , то должно выйти сообщение " 0 учеников в классе не может быть "Ответы на вопрос
Отвечает Данилкин Матвей.
Ответ:
var
m, d :integer;
part : double;
begin
writeln('Масса пирога =');
readln(m);
writeln('количество учеников =');
readln(d);
if d > 0 then begin
part := m/d;
writeln('Вес каждой части пирога = ', part:2:2)
end
else
writeln('0 учеников в классе не может быть');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая делит пирог на равные части по весу и проверяет, что количество учеников больше нуля:
pascalprogram DividePie; var PieWeight, StudentsCount, SliceWeight: real; begin write('Введите массу пирога (в граммах): '); readln(PieWeight); write('Введите количество учеников: '); readln(StudentsCount); if StudentsCount = 0 then begin writeln('Ошибка: 0 учеников в классе не может быть.'); end else begin SliceWeight := PieWeight / StudentsCount; writeln('Каждый ученик получит порцию пирога весом ', SliceWeight:0:2, ' грамм.'); end; end.
Эта программа сначала запрашивает у вас массу пирога и количество учеников в классе. Затем она проверяет, что количество учеников больше нуля, и выводит сообщение с весом порции пирога для каждого ученика. Если количество учеников равно нулю, она выводит сообщение об ошибке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
