Вопрос задан 23.06.2023 в 05:49.
Предмет Информатика.
Спрашивает Федорова Виолетта.
Пожалуйста, очень надо. Напишите программу, которая в последовательности натуральных чисел
определяет сумму всех чисел, кратных 7 и оканчивающихся на 1. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Введенные числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, подходящих по условию. кто-нибудь, умоляю, пожалуйста 20б паскальОтветы на вопрос
Отвечает Салтыкова Юлия.
var
sum,chislo:integer;
begin
while true do
begin
readln(chislo);
if chislo=0 then break;
if (chislo mod 7=0) and (chislo mod 10 = 1) then
sum+=chislo;
end;
writeln(sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая выполняет задачу:
pascalprogram SumOfMultiples; var num, sum: integer; begin sum := 0; repeat write('Введите натуральное число (0 для завершения): '); readln(num); if (num <> 0) and (num mod 7 = 0) and (num mod 10 = 1) then sum := sum + num; until num = 0; writeln('Сумма чисел, кратных 7 и оканчивающихся на 1: ', sum); end.
Эта программа будет запрашивать у вас натуральные числа до тех пор, пока вы не введете 0. Если введенное число кратно 7 и оканчивается на 1, оно будет добавлено к общей сумме. После ввода 0 программа выведет сумму всех подходящих чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
