
Вопрос задан 23.06.2023 в 05:36.
Предмет Информатика.
Спрашивает Быданцев Никита.
Помогите написать программу на pascal. Напишите программу, выводящую ряд квадратов чисел от 1 до 10
двумя способами for и while

Ответы на вопрос

Отвечает Жумабеков Ерасыл.
Ответ:
С помощью цикла for:
var
i:integer;
begin
for i:=1 to 10 do
writeln(i*i);
end.
C помощью цикла while:
var
i:integer;
begin
i:=1;
while i<=10 do
begin
writeln(i*i);
i+=1;
end;
end.
Объяснение:
i+=1 - запись равнозначна записи i:=i+1



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Ниже приведены два примера программ на Pascal для вывода квадратов чисел от 1 до 10 с использованием циклов for
и while
.
- Программа с использованием цикла
for
:
pascalprogram SquareForLoop; var i: Integer; begin writeln('Squares of numbers from 1 to 10 using for loop:'); for i := 1 to 10 do begin writeln('Square of ', i, ' is ', i * i); end; end.
- Программа с использованием цикла
while
:
pascalprogram SquareWhileLoop; var i: Integer; begin writeln('Squares of numbers from 1 to 10 using while loop:'); i := 1; while i <= 10 do begin writeln('Square of ', i, ' is ', i * i); i := i + 1; end; end.
Обе программы выводят квадраты чисел от 1 до 10, используя соответствующие циклы for
и while
.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 565

Информатика 25

Информатика 22

Информатика 27

Информатика 34

Информатика 58

Информатика 63

Информатика 23
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili