Вопрос задан 22.06.2023 в 19:58. Предмет Информатика. Спрашивает Гайдов Эмиль.

Python 1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами в

диапазоне [0,20], выводит его на экран, а затем меняет местами пары соседних элементов, кроме первого и последнего (2-й с 3-м, 4-й с 5-м и т.д.). Пример: Массив: 5 16 2 13 3 14 18 17 Реверс: 5 2 16 3 13 18 14 17
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Щербакова Вика.

Программа:
Python:

from random import randint

N = 8

arr = [randint(0, 20) for i in range(N)]

for i in arr: print(i, end=' ')

for i in range(N - 1):

   if i % 2 != 0:

       arr[i], arr[i + 1] = arr[i + 1], arr[i]

print()

for i in arr: print(i, end=' ')

Объяснение:

В начале импортируем метод randint из библиотеки random, далее - переменной N присваиваем значение 8 (как по условию). Заполняем массив N элементами в диапазоне от 0 до 20. С помощью цикла и метода print() выводим элементы через пробел.

С помощью цикла переменная i принимает значения от 0 до N - 1. Если сейчас нечётное число (а это 1, 3, 5 (без 7)), мы меняем местами текущий элемент и следующий с помощью множественного присваивания.

В конце - с помощью пустого метода print() переходим на следующую строку и с помощью цикла и метода print() выводим элементы через пробел.

Результат:

19 16 13 16 10 10 19 17

19 13 16 10 16 19 10 17

7 10 15 2 19 7 4 6

7 15 10 19 2 4 7 6

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете создать такую программу на Python. Вот пример:

python
import random # Функция для создания массива из N случайных чисел в диапазоне [0, 20] def create_random_array(N): return [random.randint(0, 20) for _ in range(N)] # Функция для вывода массива на экран def print_array(arr): print("Массив:", " ".join(map(str, arr))) # Функция для обмена соседних элементов, кроме первого и последнего def swap_neighboring_elements(arr): for i in range(1, len(arr) - 1, 2): arr[i], arr[i + 1] = arr[i + 1], arr[i] # Основная часть программы N = 8 array = create_random_array(N) print_array(array) swap_neighboring_elements(array) print("Реверс:", " ".join(map(str, array))

Этот код создает массив из 8 случайных чисел в диапазоне [0, 20], выводит его на экран, а затем меняет местами соседние элементы, начиная со второго элемента (индекс 1) и заканчивая предпоследним (индекс N-2), затем выводит результат на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос