Вопрос задан 21.06.2023 в 03:58. Предмет Информатика. Спрашивает Зубковская Татьяна.

Очень важно! Умоляю помогите! Написать программу, которая находит сумму, произведение и среднее

арифметическое 5 целых чисел.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Богомазов Тимофей.

var

_sum, _multiplication, x, i : integer;

begin

_sum := 0;

_multiplication := 1;

writeln('Введите 5 чисел: ');

for i := 1 to 5 do

begin

readln(x);

_sum := _sum + x;

_multiplication := _multiplication * x;

end;

writeln('Сумма этих чисел:', _sum);

writeln('Произведение числе:', _multiplication);

writeln('Среднее арифметическое:', _sum/5:5:2);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу для нахождения суммы, произведения и среднего арифметического пяти целых чисел. Вот пример такой программы на языке Python:

```python # Вводим пять целых чисел num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: ")) num3 = int(input("Введите третье число: ")) num4 = int(input("Введите четвертое число: ")) num5 = int(input("Введите пятое число: "))

# Вычисляем сумму sum = num1 + num2 + num3 + num4 + num5

# Вычисляем произведение product = num1 * num2 * num3 * num4 * num5

# Вычисляем среднее арифметическое average = sum / 5

# Выводим результаты print("Сумма чисел:", sum) print("Произведение чисел:", product) print("Среднее арифметическое:", average) ```

Вы можете скопировать эту программу и запустить ее на своем компьютере, чтобы получить результаты для введенных вами чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос