Вопрос задан 19.06.2023 в 16:22. Предмет Информатика. Спрашивает Масленникова Вероника.

Помогите! Это нужно сделать в python. Напишите программу, в которой в переменную very получаем

случайную последовательность трех символов ‘xyz’. Пользователь должен отгадать полученную последовательность. Вывести на экран количество попыток, за которые пользователь отгадал последовательность
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Давыдов Даниил.

from random import shuffle

very = ['x', 'y', 'z']

shuffle(very)

very = "".join(very)

flag = 0

attempt = ''

while attempt != very:

   attempt = input()

   flag += 1

print(flag)


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python для игры "Угадай последовательность". Вот пример решения:

```python import random

# Генерация случайной последовательности sequence = random.choice(['x', 'y', 'z'])

# Переменная для хранения количества попыток attempts = 0

# Цикл для игры while True: # Ввод предположения от пользователя guess = input("Введите последовательность (три символа 'x', 'y' или 'z'): ")

# Проверка правильности предположения if guess == sequence: attempts += 1 print(f"Поздравляю, вы угадали последовательность '{sequence}' за {attempts} попыток!") break else: attempts += 1 print("Вы не угадали, попробуйте еще раз.")

```

В данной программе мы используем модуль `random`, чтобы сгенерировать случайную последовательность символов

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос