
Написать программы на Pascal. 1. Написать программу, которая по двум катетам считает площадь
прямоугольного треугольника. 2. Написать программу, которая по возрасту человека может определить - совершеннолетний ли он. 3. Написать программу, которая считает кол-во цифр в числе.

Ответы на вопрос

Ответ:
1) var
a, b, c, S, P : real;
begin
write('Введите катет a : ');readln(a);
write('Введите катет b : ');readln(b);
c := sqrt(sqr(a)+sqr(b));
P := a + b + c;
S := (a*b)/2;
writeln('Периметр равен : ', P);
writeln('Площадь равна : ', S);
readln;
end.
2) program choice_2;
uses crt;
var year: integer;
begin
clrscr;
write(‘Ваш возраст > ‘); readln(year);
if (year > 0) and (year < 18) then
write(‘Вы не достигли совершеннолетия’)
else if (year > 17) and (year < 150) then
write(‘Вы достигли совершеннолетия’)
else write(‘Вероятно, введены неверные данные’);
readkey;
end.
3) uses crt;
Var n,m,p,k:integer;
Begin
write('n=');read(n);
m:=n;k:=0;
while m<>0 do begin
p:=m mod 10;
K:=K+1;
m:=m div 10;
end;
writeln('k=',k);
end.



Программа для вычисления площади прямоугольного треугольника
Для написания программы, которая будет вычислять площадь прямоугольного треугольника по двум катетам, можно использовать следующий код на языке Pascal:
```pascal program CalculateTriangleArea;
var a, b, area: real;
begin writeln('Введите длину первого катета: '); readln(a); writeln('Введите длину второго катета: '); readln(b); area := (a * b) / 2; writeln('Площадь прямоугольного треугольника: ', area); readln; end. ```
Программа для определения совершеннолетия по возрасту
Для написания программы, которая будет определять, является ли человек совершеннолетним по его возрасту, можно использовать следующий код на языке Pascal:
```pascal program CheckAdult;
var age: integer;
begin writeln('Введите возраст: '); readln(age); if age >= 18 then writeln('Человек совершеннолетний') else writeln('Человек несовершеннолетний'); readln; end. ```
Программа для подсчета количества цифр в числе
Для написания программы, которая будет подсчитывать количество цифр в числе, можно использовать следующий код на языке Pascal:
```pascal program CountDigits;
var number, count: integer;
begin writeln('Введите число: '); readln(number); count := 0; while number <> 0 do begin number := number div 10; count := count + 1; end; writeln('Количество цифр в числе: ', count); readln; end. ```
Надеюсь, эти программы помогут вам разобраться с написанием программ на языке Pascal. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili