Вопрос задан 19.06.2023 в 13:49. Предмет Информатика. Спрашивает Пайвин Никита.

Дам 100 баллов Напишите программу, которая заполняет массив из 20 элементов случайными числами на

отрезке[0; 200] и считает число двузначных чисел в массиве. в питоне​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рафиков Руслан.

Ответ:

from random import randint

a = []

count = 0

for i in range(20):

   num = randint(0,200)

   if len(str(num)) == 2:

       count +=1

   a.append(num)

print(a, 'Количество двухзначных чисел:', count)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python для создания массива из 20 элементов со случайными числами на отрезке [0; 200] и подсчета числа двузначных чисел в этом массиве. Воспользуемся библиотекой `random` для генерации случайных чисел. Для подсчета двузначных чисел можно использовать простую проверку диапазона от 10 до 99.

```python import random

# Создаем массив из 20 элементов со случайными числами на отрезке [0; 200] array = [random.randint(0, 200) for _ in range(20)]

# Выводим массив для наглядности print("Сгенерированный массив:", array)

# Считаем количество двузначных чисел в массиве count_two_digit_numbers = sum(1 for num in array if 10 <= num <= 99)

# Выводим результат print("Количество двузначных чисел в массиве:", count_two_digit_numbers) ```

Этот код создает массив из 20 случайных чисел, выводит его на экран, затем считает количество двузначных чисел в массиве и также выводит результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос