Вопрос задан 19.06.2023 в 12:30. Предмет Информатика. Спрашивает Алексеева Алёна.

Кто может помочь написать простую программку python? Напишите программу, которая в

последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ляхман Богдан.

Ответ:

numbers = []

number = input()

while number != '0':

   if len(number) == 2:

       numbers.append(int(number))

   number = input()

if len(numbers) == 0: print('NO')

else: print(sum(numbers) // len(numbers))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python. Вот пример:

```python # Инициализация переменных sum_two_digit_numbers = 0 # сумма двузначных чисел count_two_digit_numbers = 0 # количество двузначных чисел

# Ввод и обработка данных while True: num = int(input("Введите натуральное число (0 для завершения): "))

if num == 0: break # прерываем цикл при вводе 0

if 10 <= num <= 99: sum_two_digit_numbers += num count_two_digit_numbers += 1

# Проверка наличия двузначных чисел и вывод результата if count_two_digit_numbers > 0: average = sum_two_digit_numbers / count_two_digit_numbers print(f"Среднее арифметическое двузначных чисел: {average}") else: print("NO - Двузначных чисел в последовательности нет.") ```

Эта программа использует цикл `while` для ввода натуральных чисел до тех пор, пока не будет введен 0. Двузначные числа проверяются на условие `10 <= num <= 99`, и если число соответствует этому диапазону, оно учитывается в расчете среднего арифметического. Если двузначных чисел нет, программа выводит "NO".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос