
Написать программу паскаль, которая вводит с клавиатуры одномерный массив из 10 целых чисел и
вычисляет: Сколько элементов массива являются четными числами.

Ответы на вопрос

Ответ:
program test;
var i,k:integer;
a:array [1..10] of integer;
begin
k:=0;
for i:=1 to 10 do
begin
write ('a[',i,'] = ');
readln (a[i]);
if a[i] mod 2 = 0 then k:=k+1
end;
writeln;
writeln ('В массиве ',k,' элементов являются чётными числами')
end.



Конечно, вот пример программы на Pascal, которая выполняет указанную задачу:
```pascal program CountEvenNumbers;
var arr: array[1..10] of integer; i, evenCount: integer;
begin // Ввод массива с клавиатуры writeln('Введите 10 целых чисел:'); for i := 1 to 10 do begin write('Элемент ', i, ': '); readln(arr[i]); end;
// Инициализация счетчика четных чисел evenCount := 0;
// Подсчет четных чисел в массиве for i := 1 to 10 do begin if arr[i] mod 2 = 0 then evenCount := evenCount + 1; end;
// Вывод результата writeln('Количество четных элементов в массиве: ', evenCount);
readln; end. ```
В данной программе используется массив `arr`, в который вводятся 10 целых чисел с клавиатуры. Затем программа считает количество четных чисел в массиве и выводит результат. Оператор `mod 2` используется для проверки четности числа.
Надеюсь, это поможет! Если у вас есть дополнительные вопросы или нужна дополнительная помощь, не стесняйтесь спрашивать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili