Вопрос задан 18.06.2023 в 19:03. Предмет Информатика. Спрашивает Андреева Маша.

11) напишите программу, которая в последовательности натуральных чисел определяет количество всех

чётных чисел, кратных 5. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончаних ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: количество всех чётных чисел, кратных 5.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Еремеева Алина.

Ответ:

n = int(input('Введите натуральное число:'))

count = 0

count_multiple = 0

numbers = []

while count_multiple < 1000 and n != 0:

   if n > 30000:

       print('Вы ввели число больше 30000! Попробуйте еще раз')

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

   elif n % 5 == 0:

       numbers.append(n)

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

       count += 1

   else:

       n = int(input('Введите натуральное число:'))

       count_multiple += 1

print(f'количество чисел кратных пяти = {count}')

Объяснение:

Python


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для того чтобы решить данную задачу, можно использовать цикл while для последовательного считывания чисел и подсчета количества четных чисел, кратных 5.

Вначале создадим переменную count и присвоим ей значение 0. Она будет использоваться для подсчета количества четных чисел.

Затем, создадим бесконечный цикл while, который будет выполняться до тех пор, пока вводимое число не будет равно 0. Внутри цикла будем считывать число с помощью функции input.

Далее, проверим условие, является ли число четным и кратным 5. Если да, увеличим значение переменной count на 1.

После окончания цикла, выведем значение переменной count.

Вот пример кода на языке Python:

``` count = 0

while True: num = int(input("Введите число: ")) if num == 0: break if num % 2 == 0 and num % 5 == 0: count += 1

print("Количество всех четных чисел, кратных 5: ", count) ```

Эта программа будет считывать числа, до тех пор пока не будет введено 0, и подсчитывать количество четных чисел, кратных 5.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос