
Написать програму заполняющий массив из 10 нечетных чисел. В паскале


Ответы на вопрос

var
a : array[1..10] of integer;
i : integer;
begin
for i:=1 to 10 do
begin
a[i]:=i*2-1;
write(a[i],' ');
end;
end.



В Паскале можно написать программу, которая будет заполнять массив из 10 нечетных чисел следующим образом:
1. Объявим переменную `arr` как массив целых чисел с размерностью 10. 2. Объявим переменную `count` и инициализируем ее значением 1. 3. Воспользуемся циклом `for` для заполнения массива. 4. На каждой итерации цикла присваиваем элементу массива `arr[i]` значение `count` и затем увеличиваем `count` на 2. 5. Выводим полученный массив на экран.
Ниже приведен код программы на языке Паскаль:
```pascal program FillArray; var arr: array [1..10] of integer; count, i: integer; begin count := 1; for i := 1 to 10 do begin arr[i] := count; count := count + 2; end; for i := 1 to 10 do writeln(arr[i]); end. ```
После выполнение данной программы массив `arr` будет заполнен значениями `[1, 3, 5, 7, 9, 11, 13, 15, 17, 19]`.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili