Вопрос задан 18.06.2023 в 10:36. Предмет Информатика. Спрашивает Загородна Оксана.

Напишите программу, в которой необходимо организовать ввод многомерного списка (можно

использовать рандомное заполнение) и выполнение действий с ним согласно своему варианту. Для реализации программы используйте функции. ЗАДАНИЕ: Введите многомерный список, состоящий из целых чисел, количество элементов определяет пользователь. Запросите у пользователя ввести номера двух строк и поменяйте эти строки местами. Используйте функции для ввода и вывода многомерного списка и для замены строк. Python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чеботарь Стас.

import random

n, m = map(int, input().split())

a = list()

for i in range(n):

   u = list()

   for j in range(m):

       u.append(random.randint(1,1000))

   a.append(u)

k, l = map(int, input().split())

print("before changing: ")

for i in range(n):

   print(*a[i], sep=" ")

for i in range(m):

   t = a[k-1][i]

   a[k-1][i] = a[l-1][i]

   a[l-1][i] = t

print("after changing: ")

for i in range(n):

   print(*a[i], sep=" ")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая выполняет задание, описанное в вашем запросе:

```python import random

def create_matrix(rows, cols): """Создание многомерного списка с рандомными целыми числами.""" matrix = [[random.randint(1, 100) for _ in range(cols)] for _ in range(rows)] return matrix

def print_matrix(matrix): """Вывод многомерного списка.""" for row in matrix: print(row)

def swap_rows(matrix, row1, row2): """Замена двух строк в многомерном списке.""" matrix[row1], matrix[row2] = matrix[row2], matrix[row1]

def main(): # Ввод размеров многомерного списка rows = int(input("Введите количество строк: ")) cols = int(input("Введите количество столбцов: "))

# Создание многомерного списка my_matrix = create_matrix(rows, cols)

# Вывод начального состояния многомерного списка print("Исходная матрица:") print_matrix(my_matrix)

# Ввод номеров строк для замены row1 = int(input("Введите номер первой строки для замены (от 0 до {}): ".format(rows - 1))) row2 = int(input("Введите номер второй строки для замены (от 0 до {}): ".format(rows - 1)))

# Проверка введенных номеров строк if 0 <= row1 < rows and 0 <= row2 < rows: # Замена строк swap_rows(my_matrix, row1, row2)

# Вывод измененного состояния многомерного списка print("Матрица после замены строк:") print_matrix(my_matrix) else: print("Ошибка: Введенные номера строк некорректны.")

if __name__ == "__main__": main() ```

Эта программа создает многомерный список с рандомными целыми числами, выводит его, запрашивает у пользователя номера двух строк для замены и затем выполняет замену строк. Функции `create_matrix`, `print_matrix` и `swap_rows` используются для организации ввода, вывода и замены строк, соответственно.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос