Вопрос задан 18.06.2023 в 00:06. Предмет Информатика. Спрашивает Вохменцев Стас.

!Python с помощью цикла while! Напишите программу, которая в последовательности натуральных чисел

определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Платонова Майя.

Ответ:

n = int(input())

maxc = -100000000

while n > 0:

   a = int(input())

   if a % 5 == 0:

       maxc = max(maxc,a)

   n -= 1

print(maxc)

0 0
Отвечает Моренец Елена.

Ответ:

x = int(input())

a = 0

z = 0

lel = ':)'

while a < x:

   a += 1

   f = int(input())

   if f%5:

       if lel == ':)':

           lel = f

       else:

           lel = max(lel,f)

print(lel)

Если есть вопросы, пиши

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам потребуется использовать цикл while вместе с условным оператором if. Вот пример программы на Python, которая решает данную задачу:

```python # Ввод количества чисел в последовательности n = int(input("Введите количество чисел в последовательности: "))

# Инициализация переменной для хранения максимального числа, кратного 5 max_num = 0

# Цикл для ввода чисел и определения максимального числа, кратного 5 while n > 0: num = int(input("Введите число: ")) if num % 5 == 0 and num > max_num: max_num = num n -= 1

# Вывод максимального числа, кратного 5 print("Максимальное число, кратное 5: ", max_num) ```

В этой программе мы сначала запрашиваем у пользователя количество чисел в последовательности. Затем мы инициализируем переменную max_num нулевым значением, которая будет использоваться для хранения максимального числа, кратного 5.

Затем мы запускаем цикл while, который будет выполняться до тех пор, пока количество чисел в последовательности не станет равным нулю. Внутри цикла мы запрашиваем у пользователя число и проверяем, является ли оно кратным 5 и больше текущего максимального числа. Если это так, то мы обновляем значение переменной max_num.

После завершения цикла мы выводим на экран максимальное число, кратное 5.

Пример работы программы:

``` Введите количество чисел в последовательности: 5 Введите число: 10 Введите число: 15 Введите число: 7 Введите число: 25 Введите число: 20 Максимальное число, кратное 5: 25 ```

В данном примере введено 5 чисел в последовательности, и максимальное число, кратное 5, равно 25.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос