Вопрос задан 17.06.2023 в 16:55. Предмет Информатика. Спрашивает Борисов Никита.

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ НА ЯЗЫКЕ С В одном советском фильме молодые люди знакомились с

девушками, задавая им «каверзный» вопрос «Где находится нофелет?». Дело в том, что нофелет — это слово «телефон», прочитанное наоборот. Наверняка ты тоже хотя бы раз в жизни пробовал переворачивать слова и произносить их задом наперёд. Теперь же ты можешь написать программу, которая будет делать это автоматически! Напиши программу, запрашивающую у пользователя слово из семи букв и выводящую введённое слово наоборот: Подсказка: слово из семи букв — это непрерывная последовательность семи символов. Загрузи результат в виде архива с папкой проекта, созданного на языке C. Можешь также написать в ответе комментарии или пояснения к своей программе.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Василевич Даниил.

Код С:

#include <stdio.h>

int main()

{  

   char word [7];

   scanf("%s", word);

   for (int i = 6; i >= 0; i--)

       printf("%c", word[i]);

   return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке C, которая будет переворачивать слово, введенное пользователем, задом наперед. Вот пример такой программы:

```c #include #include

void reverseString(char* str) { int length = strlen(str); char temp; for (int i = 0; i < length / 2; i++) { temp = str[i]; str[i] = str[length - i - 1]; str[length - i - 1] = temp; } }

int main() { char word[8]; printf("Введите слово из семи букв: "); scanf("%s", word); if (strlen(word) != 7) { printf("Вы ввели неправильное количество букв. Пожалуйста, введите слово из семи букв.\n"); return 1; } reverseString(word); printf("Введенное слово задом наперед: %s\n", word); return 0; } ```

В этой программе мы используем функцию `reverseString`, которая принимает указатель на строку и переворачивает ее символы задом наперед. Затем в функции `main` мы сначала запрашиваем у пользователя слово из семи букв, затем проверяем его длину. Если длина не равна 7, выводим сообщение об ошибке. Если длина правильная, мы вызываем функцию `reverseString`, чтобы перевернуть введенное слово, и выводим его на экран.

Вы можете скопировать этот код в вашу среду разработки, сохранить его в виде файла с расширением `.c` и скомпилировать программу, чтобы запустить ее. После выполнения программы вы увидите введенное слово, задом наперед.

Надеюсь, это поможет вам решить вашу задачу! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать. Я всегда готов помочь.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос