Вопрос задан 17.06.2023 в 05:11. Предмет Информатика. Спрашивает Llorens Natasha.

Домашнее задание 1. Напишите программу, которая находит сумму и произведение двух целых чисел,

введённых с клавиатуры. Например, при вводе чисел 4 и 7 мы должны получить ответ 4+7=11 4*7=28 2. Ввести число, обозначающее количество секунд. Вывести то же са-мое время в минутах и секундах. Пример: Введите число секунд: 175 2 мин. 55 с
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Халус Юля.

Если нужен паскаль:

1.

var

 a,b:integer;

begin

 readln(a,b);

 writeln(a,'+',b,'=',a+b);

 writeln(a,'*',b,'=',a*b);

end.

2.

var

 n,c,m,h:integer;

begin

 readln(n);

 m:=n div 60;

 c:=n mod 60;

 if m>=60 then

   begin

     h:=m div 60;

     m:=m mod 60;

     if m<>0 then

       if c<>0 then

         write(h,'ч ',m,'мин ',c,'с')

       else

         write(h,'ч ',m,'мин ')

     else

       if c<>0 then

         write(h,'ч ',c,'с')

       else

         write(h,'ч');

   end

     else

       if m<>0 then

         if c<>0 then

           write(m,'мин ',c,'с')

         else

           write(m,'мин ')

       else

         write(c,'с');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для нахождения суммы и произведения двух целых чисел

Для написания программы, которая находит сумму и произведение двух целых чисел, введенных с клавиатуры, можно использовать язык программирования C++. Вот пример программы на C++, которая выполняет указанную задачу:

```c++ #include using namespace std;

int main() { int num1, num2; cout << "Введите два целых числа: "; cin >> num1 >> num2; int sum = num1 + num2; int product = num1 * num2; cout << "Сумма: " << num1 << " + " << num2 << " = " << sum << endl; cout << "Произведение: " << num1 << " * " << num2 << " = " << product << endl; return 0; } ```

При вводе, например, чисел 4 и 7, программа выведет: ``` Сумма: 4 + 7 = 11 Произведение: 4 * 7 = 28 ```

Программа для перевода секунд в минуты и секунды

Для написания программы, которая переводит количество секунд в минуты и секунды, также можно использовать язык программирования C++. Вот пример программы на C++, которая выполняет указанную задачу:

```c++ #include using namespace std;

int main() { int seconds, minutes, remainingSeconds; cout << "Введите количество секунд: "; cin >> seconds; minutes = seconds / 60; remainingSeconds = seconds % 60; cout << seconds << " сек. = " << minutes << " мин. " << remainingSeconds << " сек." << endl; return 0; } ```

При вводе, например, числа 175, программа выведет: ``` 175 сек. = 2 мин. 55 сек. ```

Надеюсь, эти программы помогут в выполнении задания!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос