Вопрос задан 17.06.2023 в 00:23. Предмет Информатика. Спрашивает Васильчук Артем.

Python. Оценщик малярных работ. Малярная компания установила, что на каждые 10 квадратных метров

поверхности стены требуется 5 литров краски и 8 часов работы. Компания взимает за работу 2000 руб. в час. Напишите программу, которая просит пользователя ввести площадь поверхности окрашиваемой стены и цену 5-литровой емкости краски. Программа должна показать следующие данные: • количество требующихся емкостей краски; • количество требующихся рабочих часов; • стоимость краски; • стоимость работы; • общая стоимость малярных работ. Помогите пожалуйста, я новичок и по программе должен эту задачу решить, вроде ничего сложного нет, но я путаюсь в этих def)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Иванов Михаил.

вот без def, чтобы не путаться :)

Python

s=int(input('Введите площадь стены :'))

p=int(input('Введите цену 5 литровой банки краски :'))

mprice=10/5

wprice=8/10

tprice=2000

paintcount=s/mprice / 5

if paintcount>int(paintcount):

   paintcount+=1

print('количество требующихся емкостей краски =', int(paintcount))

wcount=s*wprice

print('количество требующихся рабочих часов =', wcount)

paintprice=int(paintcount)*p

print('стоимость краски =', paintprice)

timeprice=wcount*tprice

print('стоимость работы =', timeprice)

print('общая стоимость малярных работ =', paintprice+timeprice)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает данную задачу:

```python def calculate_paint_cost(): # Ввод данных от пользователя wall_area = float(input("Введите площадь поверхности стены (в квадратных метрах): ")) paint_price = float(input("Введите цену 5-литровой емкости краски (в рублях): "))

# Расчет количества требующихся емкостей краски paint_volume = wall_area / 10 paint_cans = paint_volume / 5

# Расчет количества требующихся рабочих часов work_hours = wall_area / 10

# Расчет стоимости краски paint_cost = paint_cans * paint_price

# Расчет стоимости работы labor_cost = work_hours * 2000

# Расчет общей стоимости малярных работ total_cost = paint_cost + labor_cost

# Вывод результатов print("Количество требующихся емкостей краски:", paint_cans) print("Количество требующихся рабочих часов:", work_hours) print("Стоимость краски:", paint_cost, "руб.") print("Стоимость работы:", labor_cost, "руб.") print("Общая стоимость малярных работ:", total_cost, "руб.")

# Вызов функции для решения задачи calculate_paint_cost() ```

Программа запрашивает у пользователя площадь поверхности стены и цену 5-литровой емкости краски. Затем она выполняет необходимые расчеты и выводит результаты, включая количество требующихся емкостей краски, количество требующихся рабочих часов, стоимость краски, стоимость работы и общую стоимость малярных работ.

Примечание: В данном примере предполагается, что площадь поверхности стены и цена краски вводятся в правильном формате (например, числа с плавающей запятой). Если пользователь вводит некорректные данные, программа может выдать ошибку. Чтобы справиться с этим, можно добавить проверки на корректность введенных данных.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос