Напишите программу PASCAL с массивом, которая будет вводить массив РАНДОМНЫХ 10 чисел и сортировать
их "методом пузырька" Очень надо прошу, если не лень, то с комментариями! Даю максимум!Ответы на вопрос
Ответ:
program z;//заголовок программы
const n=10;//количество элементов в массиве (заданное через постоянное значение)
var i,j,v:integer;//описание переменных для счётчиков и обмена значениями элементов
a:array [1..n]of integer;//описание переменной массива
begin//начало программного блока
write (' Исходный массив: ');//вывод строки для красоты и понятности
for i:=1 to n do//цикл со счётчиком
begin//начало составного оператора
a[i]:=random(90)+10;//присваивание значения элементам массива
write(a[i]:4);//вывод элементов массива на экран до сортировки
end;//конец составного оператора
writeln;//переход на новую строку для красоты и понятности
for i:=1 to n-1 do//начало сортировки с использование циклов
for j:=1 to n-1 do
if a[j] > a[j+1] then//сравнение значений двух элементов массива (неполное ветвление)
begin//начало составного оператора
v:=a[j];//начало обмена значений переменных
a[j]:=a[j+1];
a[j+1]:=v
end;//конец составного оператора
write ('Преобразованный массив: ');//вывод строки для красоты и понятности
for i:=1 to n do write(a[i]:4);//вывод элементов массива на экран после сортировки
end.//конец программного блока
Конечно, я могу помочь вам написать программу на языке Pascal, которая будет вводить массив из 10 случайных чисел и сортировать его методом пузырька. Вот код программы с комментариями:
```pascal program BubbleSort;
const SIZE = 10; // Константа для определения размера массива
var arr: array[1..SIZE] of Integer; // Объявление массива целых чисел i, j, temp: Integer; // Переменные для циклов и временного хранения значения
begin Randomize; // Инициализация генератора случайных чисел
// Ввод массива случайных чисел for i := 1 to SIZE do begin arr[i] := Random(100); // Генерация случайного числа от 0 до 99 Write(arr[i], ' '); // Вывод элемента массива end; Writeln;
// Сортировка массива методом пузырька for i := 1 to SIZE - 1 do begin for j := 1 to SIZE - i do begin if arr[j] > arr[j + 1] then // Проверка, нужно ли менять элементы местами begin // Обмен значениями temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; end; end; end;
// Вывод отсортированного массива for i := 1 to SIZE do begin Write(arr[i], ' '); // Вывод элемента массива end; Writeln; end. ```
В этой программе мы используем генератор случайных чисел `Randomize` для инициализации генератора случайных чисел. Затем мы вводим массив из 10 случайных чисел, используя функцию `Random`, которая генерирует случайное число от 0 до 99. Затем мы сортируем массив методом пузырька, сравнивая каждую пару соседних элементов и меняя их местами, если они находятся в неправильном порядке. Наконец, мы выводим отсортированный массив.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
