Вопрос задан 16.06.2023 в 16:06. Предмет Информатика. Спрашивает Мельничук Ирина.

Напишите на питоне Напишите программу, которая выводит все цифры, которых не было во введенном

числе. Выводить в одну строку через пробел, порядок не важен. Пример Ввод .Вывод 100500 .6 2 7 3 8 9 4
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Листратенко Ксения.

number = input('Введите число: ')

for num in range(10):

   if str(num) not in number:

       print(num, end=' ')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Чтобы решить эту задачу на Python, можно использовать следующий код:

```python def find_missing_digits(number): all_digits = set('0123456789') number_digits = set(str(number)) missing_digits = all_digits - number_digits print(' '.join(missing_digits))

# Пример использования find_missing_digits(100500) ```

Этот код определяет функцию `find_missing_digits`, которая принимает число в качестве аргумента. Затем она создает множество `all_digits`, содержащее все цифры от 0 до 9, и множество `number_digits`, содержащее цифры введенного числа. Затем она находит разность между `all_digits` и `number_digits`, чтобы определить отсутствующие цифры, и выводит их через пробел.

В результате, если вы вызовете `find_missing_digits(100500)`, программа выведет `6 2 7 3 8 9 4`, что и является отсутствующими цифрами в числе 100500.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос