Вопрос задан 16.06.2023 в 11:39. Предмет Информатика. Спрашивает Яркина Настя.

Написать программу на языке паскаль: Задан двумерный массив 4х4 из случайно сгенерированных

чисел. Найти сумму элементов находящихся на главной диагонали.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ягодка Лайла.

var

 a:array [1..4,1..4] of integer;

 i,j,sum:integer;

begin

 sum:=0;

 for i:=1 to 4 do

   begin

     for j:=1 to 4 do

       begin

         a[i,j]:=random(101)-50;

         write(a[i,j]:4);

       end;

     sum:=sum+a[i,i];

     writeln;

   end;

 writeln('sum: ',sum);

end.

Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для нахождения суммы элементов на главной диагонали двумерного массива 4x4

```pascal program Main;

var arr: array[1..4, 1..4] of Integer; i, j, sum: Integer;

begin Randomize; // Инициализация генератора случайных чисел

// Заполнение массива случайными числами for i := 1 to 4 do begin for j := 1 to 4 do begin arr[i, j] := Random(100); // Генерация случайного числа от 0 до 99 end; end;

// Вывод массива на экран for i := 1 to 4 do begin for j := 1 to 4 do begin Write(arr[i, j]:4); end; Writeln; end;

// Нахождение суммы элементов на главной диагонали sum := 0; for i := 1 to 4 do begin sum := sum + arr[i, i]; end;

// Вывод суммы на экран Writeln('Сумма элементов на главной диагонали: ', sum);

end. ```

Объяснение программы: - Программа начинается с объявления переменных: `arr` - двумерный массив 4x4 для хранения случайно сгенерированных чисел, `i` и `j` - переменные для циклов, `sum` - переменная для хранения суммы элементов на главной диагонали. - Затем используется функция `Randomize` для инициализации генератора случайных чисел. - Далее происходит заполнение массива `arr` случайными числами с помощью вложенных циклов. - После заполнения массива происходит вывод его содержимого на экран. - Затем с помощью цикла происходит нахождение суммы элементов на главной диагонали массива. - Наконец, программа выводит полученную сумму на экран.

Пример вывода: ``` 12 45 78 23 56 89 34 67 90 43 76 21 54 87 32 65 Сумма элементов на главной диагонали: 242 ```

Примечание: - В данной программе используется функция `Random`, которая генерирует случайное число от 0 до указанного значения минус 1. В данном случае, `Random(100)` генерирует случайное число от 0 до 99. Если вам нужно изменить диапазон случайных чисел, вы можете изменить аргумент функции `Random` соответствующим образом.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос