Вопрос задан 16.06.2023 в 06:54. Предмет Информатика. Спрашивает Хороля Мария.

Напишите в питоне пожалуйста, Какая строка получится в результате применения приведённой ниже

программы к строке, состоящей из 70 идущих подряд цифр 8? В ответе запишите полученную строку. НАЧАЛО ПОКА нашлось (2222) ИЛИ нашлось (8888) ЕСЛИ нашлось (2222) ТО заменить (2222, 88) ИНАЧЕ заменить (8888, 22) КОНЕЦ ЕСЛИ КОНЕЦ ПОКА КОНЕЦ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Павлов Саша.

Ответ:

str_8_70 = ''

for i in range(70):

   str_8_70 += '8'

while True:

   if str_8_70.find('2222') != -1 or str_8_70.find('8888') != -1:

       if str_8_70.find('2222') != -1:

           str_8_70 = str_8_70.replace('2222', '88')

       else:

           str_8_70 = str_8_70.replace('8888', '22')

   else:

       break

print(str_8_70)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Данная программа будет искать подстроки "2222" и "8888" в строке и заменять их соответствующим образом. Если в строке найдена подстрока "2222", она будет заменена на "88". Если подстрока "2222" не найдена, но найдена подстрока "8888", она будет заменена на "22". Процесс будет повторяться, пока в строке не будут найдены обе подстроки "2222" и "8888".

Для заданной строки, состоящей из 70 цифр 8 подряд, программа будет выполнять замены следующим образом:

  1. Замена "2222" на "88": 88888888888888888888888888888888888888888888888888888888888888888888888888888888888888

  2. Замена "8888" на "22": 22222222222222222222222222222222222222222222222222222222222222222222222222222222222222

  3. Замена "2222" на "88": 88888888888888888888888888888888888888888888888888888888888888888888888888888888888888

  4. Замена "8888" на "22": 22222222222222222222222222222222222222222222222222222222222222222222222222222222222222

После выполнения программы, получаем строку из 70 идущих подряд цифр "2".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос