Написать программу вычисления наибольшего общего делителя двух целых чисел,с помощью оператора for
. ПаскальОтветы на вопрос
Ответ:
var
k, l, n: integer;
function nod (var a,b: integer): integer;
var c: integer;
begin
repeat
if a > b then
a := a mod b
else
b := b mod a;
until (a = 0) or (b = 0);
nod := a + b;
end;
begin
writeln ('Введите два числа: ');
readln (k, l);
n := nod (k, l);
writeln ('НОД = ', n);
readln
end.
Конечно! Вот пример программы на языке Паскаль, которая вычисляет наибольший общий делитель (НОД) двух целых чисел с использованием оператора for:
pascalprogram GCD; var num1, num2, i, gcd: integer; begin writeln('Введите два целых числа:'); readln(num1, num2); gcd := 1; for i := 1 to num1 do begin if (num1 mod i = 0) and (num2 mod i = 0) then gcd := i; end; writeln('Наибольший общий делитель чисел ', num1, ' и ', num2, ' равен ', gcd); end.
Программа запрашивает у пользователя два целых числа num1 и num2. Затем она использует оператор for для итерации по всем числам от 1 до num1. Внутри цикла проверяется, является ли текущее число делителем и num1, и num2. Если число является делителем обоих чисел, то оно присваивается переменной gcd.
По окончании цикла программа выводит наибольший общий делитель чисел num1 и num2.
Пожалуйста, обратите внимание, что в этом примере не предусмотрены проверки на некорректный ввод пользователем, поэтому необходимо быть внимательным при использовании этого кода.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
