
Помогите с домашкой на паскале. Напишите программу нахождения среднего арифметического
минимального из кратных 3 и минимального из кратных 10 элементов массива A[1:30] заполненного произвольными числами в диапазоне [0,50].

Ответы на вопрос

Программа:
Pascal:
const n = 30; // кол-во элементов в массиве
var
arr: array[1..n] of integer;
i, minThree, minTen: integer;
begin
minThree := MAXINT;
minTen := MAXINT;
for i := 1 to n do
begin
arr[i] := random(50); // заполнение случайными числами от 0 до 50
if (arr[i] mod 3 = 0) and (arr[i] < minThree) then // если число кратно трём и оно меньше текущего минимального числа, то...
minThree := arr[i]; // присвоить переменной minThree значение этой переменной
if (arr[i] mod 10 = 0) and (arr[i] < minTen) then
minTen := minThree;
end;
writeln('Массив: ', arr);
writeln('Среднее арифметическое чисел (по условию): ', (minThree + minTen) / 2);
end.



Конечно! Вот программа на языке Паскаль, которая решает вашу задачу:
pascalprogram AverageMinMultiples; const N = 30; // Размер массива RangeStart = 0; // Начальное значение диапазона RangeEnd = 50; // Конечное значение диапазона var A: array[1..N] of Integer; // Массив i, minMultiple3, minMultiple10, sum, count3, count10: Integer; avg: Real; begin // Инициализация генератора случайных чисел Randomize; // Заполнение массива случайными числами for i := 1 to N do A[i] := Random(RangeEnd - RangeStart + 1) + RangeStart; // Нахождение минимального элемента, кратного 3 minMultiple3 := RangeEnd + 1; // Инициализируем значением, большим диапазона for i := 1 to N do begin if (A[i] mod 3 = 0) and (A[i] < minMultiple3) then minMultiple3 := A[i]; end; // Нахождение минимального элемента, кратного 10 minMultiple10 := RangeEnd + 1; // Инициализируем значением, большим диапазона for i := 1 to N do begin if (A[i] mod 10 = 0) and (A[i] < minMultiple10) then minMultiple10 := A[i]; end; // Вычисление среднего арифметического sum := 0; count3 := 0; count10 := 0; for i := 1 to N do begin if A[i] mod 3 = 0 then begin sum := sum + A[i]; count3 := count3 + 1; end; if A[i] mod 10 = 0 then begin sum := sum + A[i]; count10 := count10 + 1; end; end; if (count3 > 0) and (count10 > 0) then avg := sum / (count3 + count10) else avg := 0; // Вывод результатов writeln('Минимальное кратное 3: ', minMultiple3); writeln('Минимальное кратное 10: ', minMultiple10); writeln('Среднее арифметическое: ', avg:0:2); readln; end.
Программа генерирует массив случайных чисел, находит минимальный элемент, кратный 3, и минимальный элемент, кратный 10. Затем она вычисляет среднее арифметическое минимального элемента, кратного 3, и минимального элемента, кратного 10, и выводит результаты на экран.


Похожие вопросы


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili