
Нужна помощь в написании программы на C# Найти действительные корни квадратного уравнения для
любых вводимых значений коэффициентов. Рассмотреть ситуации: а=0 D<0 , и обычное решение с двумя корнями

Ответы на вопрос

using System;
class HelloWorld {
static void Main() {
double a = Convert.ToDouble(Console.ReadLine());
double b = Convert.ToDouble(Console.ReadLine());
double c = Convert.ToDouble(Console.ReadLine());
double D = b*b-4*a*c;
double D_2 = Convert.ToDouble(Math.Sqrt(D));
double x_1 = (-b + D_2) / 2 * a;
double x_2 = (-b - D_2) / 2 * a;
if (D > 0)
{
Console.WriteLine("X1 = " + x_1);
Console.WriteLine("X2 = " + x_2);
}
if (D == 0)
{
Console.WriteLine("x = " + x_1);
}
else
{
Console.WriteLine("Корней нет");
}
}
}



Конечно! Я могу помочь вам написать программу на C#, которая найдет действительные корни квадратного уравнения для любых вводимых значений коэффициентов. Вот пример программы:
csharpusing System;
class Program
{
static void Main(string[] args)
{
Console.WriteLine("Введите коэффициенты a, b и c квадратного уравнения (ax^2 + bx + c = 0):");
Console.Write("a: ");
double a = double.Parse(Console.ReadLine());
Console.Write("b: ");
double b = double.Parse(Console.ReadLine());
Console.Write("c: ");
double c = double.Parse(Console.ReadLine());
double discriminant = b * b - 4 * a * c;
if (a == 0)
{
Console.WriteLine("Уравнение не является квадратным.");
}
else if (discriminant < 0)
{
Console.WriteLine("Уравнение не имеет действительных корней.");
}
else
{
double x1 = (-b + Math.Sqrt(discriminant)) / (2 * a);
double x2 = (-b - Math.Sqrt(discriminant)) / (2 * a);
Console.WriteLine("Первый корень (x1): " + x1);
Console.WriteLine("Второй корень (x2): " + x2);
}
Console.ReadLine();
}
}
В этой программе мы сначала запрашиваем у пользователя коэффициенты a, b и c квадратного уравнения через консольный ввод. Затем мы вычисляем дискриминант и проверяем несколько сценариев.
Если a равно нулю, выводится сообщение о том, что уравнение не является квадратным. Если дискриминант меньше нуля, выводится сообщение о том, что уравнение не имеет действительных корней. В противном случае вычисляются два корня (x1 и x2) с использованием формулы корней квадратного уравнения и выводятся на экран.
Вы можете скопировать этот код в среду разработки C# (например, Visual Studio) и запустить его для проверки.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili